Ubicloud Cache and DockerHub unavailability

Incident Report for Ubicloud

Resolved

The outages have been resolved by Cloudflare and DockerHub teams. All operations on Ubicloud runners are back to normal.
Posted Feb 06, 2025 - 09:54 UTC

Monitoring

Posted Feb 06, 2025 - 09:02 UTC

Investigating

Cloudflare R2 is currently experiencing a major outage, causing blob storage requests to R2 buckets to fail. As a result, the caches can't be downloaded from Ubicloud Cache service. We are keeping an eye on updates from the Cloudflare team.

https://www.cloudflarestatus.com/incidents/pgz7g5xlpxzr

Failures while pulling images from DockerHub also started to increase around the same time. It seems that DockerHub was affected by the Cloudflare R2 outage as well.

https://www.dockerstatus.com/pages/incident/533c6539221ae15e3f000031/67a479b283fb1305d10af103
Posted Feb 06, 2025 - 08:39 UTC
This incident affected: GitHub Actions Service (Ubicloud Runners).