Degraged GitHub Webhooks

Incident Report for Ubicloud

Resolved

This incident has been resolved.
Posted May 19, 2026 - 17:31 UTC

Identified

At approximately 14:55 UTC, we observed a drop in incoming GitHub webhooks as GitHub temporarily stopped sending events. Delivery has since partially recovered.
Our system automatically detects missing webhooks every 5 minutes and self-heals by reconciling the missed events. As a result, you may experience longer-than-usual job assignment times until delivery fully stabilizes.
We are continuing to monitor the situation.
Posted May 19, 2026 - 15:05 UTC
This incident affected: GitHub Actions Service (GitHub Webhooks).