Degraded Performance in GitHub API

Incident Report for Ubicloud

Resolved

GitHub API has stopped returning HTTP 503 errors, and operations are back to normal.
Posted Sep 26, 2025 - 15:39 UTC

Investigating

Our monitors have detected an increased number of "503 - github-launch service unavailable" errors from the GitHub API over the past 30 minutes. This affects the time it takes for jobs to be picked up by runners. We believe this may be due to an undeclared GitHub incident and are closely monitoring the situation.
Posted Sep 26, 2025 - 14:32 UTC
This incident affected: GitHub Actions Service (GitHub API Requests).