Occassional DNS Resolution Failures

Incident Report for Ubicloud

Resolved

Caused by a DDOS attack against Hetzner and its mitigation routines. We will be diversifying our DNS upstreams in the future.
Posted Feb 25, 2026 - 22:50 UTC

Identified

DNS queries can fail sporadically, linked to a UDP-related fault at Hetzner https://status.hetzner.com/incident/5e901309-0873-42af-90c5-84f38304f592

We're monitoring and looking to work around this issue.
Posted Feb 25, 2026 - 21:15 UTC
This incident affected: Compute, PostgreSQL, Networking, and Kubernetes.